How to contact Library

Issue/Question

  • I need help finding an article.
  • I need help using the library search tool.
  • I need help using one of the databases.
  • Alumni needing Library access

Environment

User Role

  • Students

Cause(s)

  • When I use the search tool, I receive a '502 Bad Gateway' error message.
  • There are missing links or information when I search for specific articles.
  • Alumni access to library tools. More information can be found at https://library.usa.edu/alumni

Resolution

 

The library has its own help center on its page, which has multiple options for contacting its team.

Ask Us

You can use the 'Ask Us' tool at https://library.usa.edu/ to contact the library directly.

Chat & text services are available:

7 Days a Week: 8 AM - 6 PM Central Time

  • Please note that this chat covers library topics such as
  • Asking general library-related questions
  • Getting help with databases
  • Finding peer-reviewed sources
  • Retrieving full-text articles
  • Doubts about Interlibrary Loan requests (ILL)

If chat is not available for library questions, e-mail us at library@usa.edu.

For simple questions, TEXT us (character limits apply; this number will not work for phone calls): 904-822-8728

 

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